[webkit-reviews] review granted: [Bug 194160] Don't use base layer() as the scroll layer in scrolling tree. : [Attachment 360869] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 1 11:13:01 PST 2019


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Antti Koivisto
<koivisto at iki.fi>'s request for review:
Bug 194160: Don't use base layer() as the scroll layer in scrolling tree.
https://bugs.webkit.org/show_bug.cgi?id=194160

Attachment 360869: patch

https://bugs.webkit.org/attachment.cgi?id=360869&action=review




--- Comment #5 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 360869
  --> https://bugs.webkit.org/attachment.cgi?id=360869
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=360869&action=review

> Source/WebCore/page/scrolling/ScrollingTreeScrollingNode.h:143
> +#if PLATFORM(COCOA)
> +    RetainPtr<CALayer> m_scrollContainerLayer;
> +    RetainPtr<CALayer> m_scrolledContentsLayer;
> +#endif

This is breaking the platform-neutrality of this class. Maybe that's OK? Or
maybe we should have some kind of platform mixin for the layer management?

> Source/WebCore/rendering/RenderLayerCompositor.cpp:556
> +	       nodeLayers = { layer.backing()->graphicsLayer(),
backing->scrollingLayer(), backing->scrollingContentsLayer() };

Do you want to rename backing->scrollingLayer() in this patch?


More information about the webkit-reviews mailing list