[webkit-reviews] review granted: [Bug 205632] Create media mime type cache base class to reduce duplicate code : [Attachment 386504] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Dec 29 22:31:39 PST 2019


Jer Noble <jer.noble at apple.com> has granted Eric Carlson
<eric.carlson at apple.com>'s request for review:
Bug 205632: Create media mime type cache base class to reduce duplicate code
https://bugs.webkit.org/show_bug.cgi?id=205632

Attachment 386504: Patch

https://bugs.webkit.org/attachment.cgi?id=386504&action=review




--- Comment #5 from Jer Noble <jer.noble at apple.com> ---
Comment on attachment 386504
  --> https://bugs.webkit.org/attachment.cgi?id=386504
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=386504&action=review

r=me with nits. 

> Source/WebCore/platform/graphics/MIMETypeCache.h:48
> +    WEBCORE_EXPORT void setSupportedTypes(const Vector<String>&);

Nit: The implementation doesn’t match the name here. It doesn’t replace the
existing set of supported types, instead it adds new types to the existing set.
‘addSupportedTypes’ maybe?

>
Source/WebCore/platform/graphics/avfoundation/objc/MediaPlayerPrivateMediaSourc
eAVFObjC.mm:263
> +    if (AVStreamDataParserMIMETypeCache::singleton().isAvailable())

This could use a “auto cache = ...” so you’re not calling the singleton()
method so much.


More information about the webkit-reviews mailing list