[webkit-reviews] review granted: [Bug 205592] [JSC] StructureChain should hold vector of StructureID : [Attachment 386406] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 27 22:36:22 PST 2019


Mark Lam <mark.lam at apple.com> has granted Yusuke Suzuki <ysuzuki at apple.com>'s
request for review:
Bug 205592: [JSC] StructureChain should hold vector of StructureID
https://bugs.webkit.org/show_bug.cgi?id=205592

Attachment 386406: Patch

https://bugs.webkit.org/attachment.cgi?id=386406&action=review




--- Comment #3 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 386406
  --> https://bugs.webkit.org/attachment.cgi?id=386406
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=386406&action=review

r=me

> Source/JavaScriptCore/runtime/Structure.cpp:1217
> +    StructureID* structureIDVector = structureChain->head();

nit: I think "structureIDPointer" is a better name than "structureIDVector"
here since we're using it as a bump pointer and not a vector.  Alternatively,
"currentStructureID" or "structureIDIterator" also works.

> Source/JavaScriptCore/runtime/StructureChain.cpp:67
> +	   vm.heap.writeBarrier(this);

Now that we're storing structureIDs and not setting a list of
WriteBarrier<Structure>, I think we can put this writeBarrier() call after the
loop.  There's nothing gained by calling it repeatedly in the loop.


More information about the webkit-reviews mailing list