[webkit-reviews] review granted: [Bug 205553] [JSC] Compact Bytecodes more by emitting 1-byte Opcode : [Attachment 386330] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 24 10:18:03 PST 2019


Keith Miller <keith_miller at apple.com> has granted Yusuke Suzuki
<ysuzuki at apple.com>'s request for review:
Bug 205553: [JSC] Compact Bytecodes more by emitting 1-byte Opcode
https://bugs.webkit.org/show_bug.cgi?id=205553

Attachment 386330: Patch

https://bugs.webkit.org/attachment.cgi?id=386330&action=review




--- Comment #11 from Keith Miller <keith_miller at apple.com> ---
Comment on attachment 386330
  --> https://bugs.webkit.org/attachment.cgi?id=386330
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=386330&action=review

r=me with some comments.

> Source/JavaScriptCore/llint/LowLevelInterpreter.asm:322
> +	   dispatch((constexpr %opcodeName%_length - 1) * 2 + 2)

Can you use names for these constants? I always find it like to read the code
later and have names for the various numbers so I don't have to figure it out.
In this case, it would be great if there were:

const OpcodeIDWide16Size = 2 # Wide16 Prefix + OpcodeID.

Ditto for the other sizes.

Also, can you put the comment Robin suggested here too.


More information about the webkit-reviews mailing list