[webkit-reviews] review granted: [Bug 202992] Service Worker doesn't terminate after a period of time when thread blocking : [Attachment 384610] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 9 16:14:53 PST 2019


Chris Dumez <cdumez at apple.com> has granted youenn fablet <youennf at gmail.com>'s
request for review:
Bug 202992: Service Worker doesn't terminate after a period of time when thread
blocking
https://bugs.webkit.org/show_bug.cgi?id=202992

Attachment 384610: Patch

https://bugs.webkit.org/attachment.cgi?id=384610&action=review




--- Comment #14 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 384610
  --> https://bugs.webkit.org/attachment.cgi?id=384610
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=384610&action=review

r=me with changes

> Source/WebCore/workers/service/context/SWContextManager.h:72
> +	   bool useShortTimeout() const { return m_useShortTimeout; }

usesShortTimeout() or shouldUseShortTimeout(), it is confusing otherwise as it
looks like it may be a setter.

> Source/WebCore/workers/service/context/SWContextManager.h:76
> +	   void setUseShortTimeout(bool value) { m_useShortTimeout = value; }

Ditto about naming.

> Source/WebCore/workers/service/context/SWContextManager.h:80
> +	   bool m_useShortTimeout { false };

Ditto about naming.

> Source/WebKit/UIProcess/API/C/WKPreferencesRef.h:346
> +WK_EXPORT bool WKPreferencesGetServiceWorkerShortTimeout(WKPreferencesRef
preferencesRef);

Name is confusing for a boolean

> Source/WebKit/UIProcess/API/C/WKPreferencesRef.h:347
> +WK_EXPORT void WKPreferencesSetServiceWorkerShortTimeout(WKPreferencesRef
preferencesRef, bool enabled);

Name is confusing for a boolean


More information about the webkit-reviews mailing list