[webkit-reviews] review granted: [Bug 205001] Add encoding and decoding support for more DisplayListItems : [Attachment 385132] WIP

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Dec 8 21:08:56 PST 2019


Tim Horton <thorton at apple.com> has granted  review:
Bug 205001: Add encoding and decoding support for more DisplayListItems
https://bugs.webkit.org/show_bug.cgi?id=205001

Attachment 385132: WIP

https://bugs.webkit.org/attachment.cgi?id=385132&action=review




--- Comment #3 from Tim Horton <thorton at apple.com> ---
Comment on attachment 385132
  --> https://bugs.webkit.org/attachment.cgi?id=385132
WIP

View in context: https://bugs.webkit.org/attachment.cgi?id=385132&action=review

> Source/WebCore/platform/graphics/GraphicsTypes.h:199
> +    WebCore::LineCap::ButtCap,

At some point we should enum class these (and drop the suffixes). I'd mostly
been doing that as I went along, but I can see why you might not want to :D

> Source/WebCore/platform/graphics/displaylists/DisplayListItems.h:533
> +void SetLineCap::encode(Encoder& encoder) const

Wonder why these aren't in the State thing

> Source/WebCore/platform/graphics/displaylists/DisplayListItems.h:1233
> +    encoder << m_point1 << m_point2;

I don't love multiple items on one line.

> Source/WebCore/platform/graphics/displaylists/DisplayListItems.h:1358
> +    encoder << m_rect << m_style;

Ditto

> Source/WebCore/platform/graphics/displaylists/DisplayListItems.h:1845
> +    encoder << m_rect;

Much better


More information about the webkit-reviews mailing list