[webkit-reviews] review granted: [Bug 201169] Add support for postMessage buffering between the service worker and window : [Attachment 377442] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 28 09:33:11 PDT 2019


youenn fablet <youennf at gmail.com> has granted Chris Dumez <cdumez at apple.com>'s
request for review:
Bug 201169: Add support for postMessage buffering between the service worker
and window
https://bugs.webkit.org/show_bug.cgi?id=201169

Attachment 377442: Patch

https://bugs.webkit.org/attachment.cgi?id=377442&action=review




--- Comment #13 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 377442
  --> https://bugs.webkit.org/attachment.cgi?id=377442
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=377442&action=review

> Source/WebCore/dom/Document.cpp:324
> +#if ENABLE(SERVICE_WORKER)

No need for ENABLE(SERVICE_WORKER), ServiceWorkerContainer.h is doing it
itself.

> Source/WebCore/workers/service/SWClientConnection.cpp:129
> +	   container->postMessage(WTFMove(message), WTFMove(sourceData),
WTFMove(sourceOrigin));

If we want to keep the fact that we are actually posting a task to dispatch a
message event, we could rename this postMessage method.


More information about the webkit-reviews mailing list