[webkit-reviews] review granted: [Bug 200819] [ContentChangeObserver] Add ContentChangeObserver::elementDidBecomeHidden : [Attachment 376511] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 16 12:00:50 PDT 2019


Simon Fraser (smfr) <simon.fraser at apple.com> has granted zalan
<zalan at apple.com>'s request for review:
Bug 200819: [ContentChangeObserver] Add
ContentChangeObserver::elementDidBecomeHidden
https://bugs.webkit.org/show_bug.cgi?id=200819

Attachment 376511: Patch

https://bugs.webkit.org/attachment.cgi?id=376511&action=review




--- Comment #3 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 376511
  --> https://bugs.webkit.org/attachment.cgi?id=376511
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=376511&action=review

> Source/WebCore/page/ios/ContentChangeObserver.cpp:415
> +    LOG(ContentObservation, "elementDidBecomeHidden: element went from
visible to hidden");

Log the element addresss.

> Source/WebCore/page/ios/ContentChangeObserver.cpp:652
> +    auto wasHidden = m_wasHidden.value();
> +    auto isVisible = isConsideredVisible(m_element);

Can we just use "hidden" or "visible" in both code paths?


More information about the webkit-reviews mailing list