[webkit-reviews] review granted: [Bug 200463] [WHLSL] Reduce the number of variables that make it into the global struct by skipping stdlib functions and internal uses of MakePointerExpression/MakeArrayReference : [Attachment 375602] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 5 23:19:58 PDT 2019


Myles C. Maxfield <mmaxfield at apple.com> has granted Saam Barati
<sbarati at apple.com>'s request for review:
Bug 200463: [WHLSL] Reduce the number of variables that make it into the global
struct by skipping stdlib functions and internal uses of
MakePointerExpression/MakeArrayReference
https://bugs.webkit.org/show_bug.cgi?id=200463

Attachment 375602: patch

https://bugs.webkit.org/attachment.cgi?id=375602&action=review




--- Comment #3 from Myles C. Maxfield <mmaxfield at apple.com> ---
Comment on attachment 375602
  --> https://bugs.webkit.org/attachment.cgi?id=375602
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=375602&action=review

> Source/WebCore/Modules/webgpu/WHLSL/WHLSLChecker.cpp:128
> +    return AST::NativeFunctionDeclaration(AST::FunctionDeclaration(location,
AST::AttributeBlock(), WTF::nullopt, WTFMove(returnType), String("operator&[]",
String::ConstructFromLiteral), WTFMove(parameters), nullptr, isOperator,
ParsingMode::StandardLibrary));

Wouldn't all native functions be marked as StandardLibrary?

> Source/WebCore/Modules/webgpu/WHLSL/WHLSLParser.cpp:62
> +auto Parser::parse(Program& program, StringView stringView, ParsingMode
mode) -> Expected<void, Error>

is "ParsingMode" really the best name for this? It doesn't have much to do with
parsing.


More information about the webkit-reviews mailing list