[webkit-reviews] review granted: [Bug 197304] CodeBlock::m_instructionCount is wrong : [Attachment 368623] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 30 16:17:39 PDT 2019


Yusuke Suzuki <ysuzuki at apple.com> has granted Saam Barati <sbarati at apple.com>'s
request for review:
Bug 197304: CodeBlock::m_instructionCount is wrong
https://bugs.webkit.org/show_bug.cgi?id=197304

Attachment 368623: patch

https://bugs.webkit.org/attachment.cgi?id=368623&action=review




--- Comment #4 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 368623
  --> https://bugs.webkit.org/attachment.cgi?id=368623
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=368623&action=review

r=me

> Source/JavaScriptCore/dfg/DFGDisassembler.cpp:77
> +    out.print("Generated DFG JIT code for ",
CodeBlockWithJITType(m_graph.m_codeBlock, JITType::DFGJIT), ", instruction
count = ", m_graph.m_codeBlock->instructionsSize(), ":\n");

It would be nice if we can consistently use `instructions size` instead of
`instruction count` in the log too.

> Source/JavaScriptCore/dfg/DFGDriver.cpp:88
> +	   dataLog("DFG(Driver) compiling ", *codeBlock, " with ", mode, ",
number of instructions = ", codeBlock->instructionsSize(), "\n");

Ditto.

> Source/JavaScriptCore/dfg/DFGPlan.cpp:187
> +	   dataLog("DFG(Plan) compiling ", *m_codeBlock, " with ", m_mode, ",
number of instructions = ", m_codeBlock->instructionsSize(), "\n");

Ditto.

> Source/JavaScriptCore/ftl/FTLCompile.cpp:171
> +	   out.print("Generated ", state.graph.m_plan.mode(), " code for ",
CodeBlockWithJITType(state.graph.m_codeBlock, JITType::FTLJIT), ", instruction
count = ", state.graph.m_codeBlock->instructionsSize(), ":\n");

Ditto.

> Source/JavaScriptCore/ftl/FTLLink.cpp:74
> +	       toCString("Generated FTL JIT code for ",
CodeBlockWithJITType(codeBlock, JITType::FTLJIT), ", instruction count = ",
graph.m_codeBlock->instructionsSize(), ":\n"));

Ditto.

> Source/JavaScriptCore/jit/JIT.cpp:908
>      m_vm->machineCodeBytesPerBytecodeWordForBaselineJIT->add(

I think `machineCodeBytesPerBytecodeWordForBaselineJIT` name becomes wrong now.

> Source/JavaScriptCore/jit/JITDisassembler.cpp:92
> +    out.print("Generated Baseline JIT code for ",
CodeBlockWithJITType(m_codeBlock, JITType::BaselineJIT), ", instruction count =
", m_codeBlock->instructionsSize(), "\n");

Ditto.

> Source/JavaScriptCore/profiler/ProfilerBytecodes.cpp:43
> +    , m_instructionCount(codeBlock->instructionsSize())

Should we rename this to `m_instructionsSize` too?


More information about the webkit-reviews mailing list