[webkit-reviews] review granted: [Bug 197231] Rename _highlightLongPressCanClick and only add gesture recognizer when necessary : [Attachment 368119] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 24 05:15:14 PDT 2019

Antoine Quint <graouts at apple.com> has granted Dean Jackson <dino at apple.com>'s
request for review:
Bug 197231: Rename _highlightLongPressCanClick and only add gesture recognizer
when necessary

Attachment 368119: Patch


--- Comment #3 from Antoine Quint <graouts at apple.com> ---
Comment on attachment 368119
  --> https://bugs.webkit.org/attachment.cgi?id=368119

View in context: https://bugs.webkit.org/attachment.cgi?id=368119&action=review

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:756
> +    }

Maybe I'm not used to this kind of use of a block, but this looks a bit nasty
to have this code only be conditionalized with a build-time flag. Could we have
this wrapped in a function with an early return if the build-time flag and
condition are as expected?

More information about the webkit-reviews mailing list