[webkit-reviews] review granted: [Bug 177484] requestAnimationFrame should execute before the next frame : [Attachment 366413] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 1 12:53:38 PDT 2019


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Said Abou-Hallawa
<sabouhallawa at apple.com>'s request for review:
Bug 177484: requestAnimationFrame should execute before the next frame
https://bugs.webkit.org/show_bug.cgi?id=177484

Attachment 366413: Patch

https://bugs.webkit.org/attachment.cgi?id=366413&action=review




--- Comment #105 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 366413
  --> https://bugs.webkit.org/attachment.cgi?id=366413
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=366413&action=review

> Source/WebCore/animation/DocumentTimeline.cpp:272
> +    if (!m_cachedCurrentTime)
> +	   cacheCurrentTime(liveCurrentTime());
> +    
>      return m_cachedCurrentTime.value() - m_originTime;

Later (not in this patch) would should move cached time management to something
that knows about the event loop.

> Source/WebCore/page/Page.cpp:1262
> +void Page::renderingUpdate()

This should be called updateRendering()

> Source/WebCore/page/Page.cpp:1295
> +}

This needs another layoutIfNeeded at the end.

> Source/WebKit/WebProcess/WebPage/WebPage.cpp:3644
> +void WebPage::renderingUpdate()

This should be called updateRendering()

> Source/WebKit/WebProcess/WebPage/mac/TiledCoreAnimationDrawingArea.mm:460
> +    TraceScope traceScope(RenderingUpdateStart, RenderingUpdateEnd);

This scope should go inside page::updateRendering().


More information about the webkit-reviews mailing list