[webkit-reviews] review granted: [Bug 189780] [JSC] Optimize Array#lastIndexOf : [Attachment 350179] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 24 11:05:21 PDT 2018


Saam Barati <sbarati at apple.com> has granted Yusuke Suzuki
<yusukesuzuki at slowstart.org>'s request for review:
Bug 189780: [JSC] Optimize Array#lastIndexOf
https://bugs.webkit.org/show_bug.cgi?id=189780

Attachment 350179: Patch

https://bugs.webkit.org/attachment.cgi?id=350179&action=review




--- Comment #2 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 350179
  --> https://bugs.webkit.org/attachment.cgi?id=350179
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=350179&action=review

> Source/JavaScriptCore/runtime/ArrayPrototype.cpp:1274
> +    if (isJSArray(thisObject)) {

There is a ton of duplicate code here with indexOf. Can we abstract away the
way we iterate and combine these two implementations?


More information about the webkit-reviews mailing list