[webkit-reviews] review denied: [Bug 189633] Add size() function to OptionSet : [Attachment 350150] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 20 10:53:13 PDT 2018


Simon Fraser (smfr) <simon.fraser at apple.com> has denied  review:
Bug 189633: Add size() function to OptionSet
https://bugs.webkit.org/show_bug.cgi?id=189633

Attachment 350150: Patch

https://bugs.webkit.org/attachment.cgi?id=350150&action=review




--- Comment #23 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 350150
  --> https://bugs.webkit.org/attachment.cgi?id=350150
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=350150&action=review

> Source/WTF/wtf/OptionSet.h:127
> +    constexpr unsigned size() const
> +    {
> +	   return WTF::countSetBits(m_storage);
> +    }

I agree that this should not be called size().


More information about the webkit-reviews mailing list