[webkit-reviews] review granted: [Bug 189277] [WebAuthN] Polish AuthenticatorManager and rename it to AuthenticatorCoordinator : [Attachment 349318] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 10 12:35:41 PDT 2018


Chris Dumez <cdumez at apple.com> has granted Jiewen Tan <jiewen_tan at apple.com>'s
request for review:
Bug 189277: [WebAuthN] Polish AuthenticatorManager and rename it to
AuthenticatorCoordinator
https://bugs.webkit.org/show_bug.cgi?id=189277

Attachment 349318: Patch

https://bugs.webkit.org/attachment.cgi?id=349318&action=review




--- Comment #5 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 349318
  --> https://bugs.webkit.org/attachment.cgi?id=349318
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=349318&action=review

r=me with suggestions.

> Source/WebCore/Modules/webauthn/PublicKeyCredentialCreationOptions.h:98
> +    encoder.encodeFixedLengthData(reinterpret_cast<const
uint8_t*>(user.id.data()), user.id.length(), 1);

Why do we need the reinterpret_cast here?

Also, it seems like this could construct a temporary IPC::DataReference and
encode that.

> Source/WebCore/page/Page.h:910
> +    std::unique_ptr<AuthenticatorCoordinator> m_authenticatorCoordinator;

Could this be a UniqueRef instead of a unique_ptr? It seems it cannot be null.


More information about the webkit-reviews mailing list