[webkit-reviews] review granted: [Bug 191794] [WebGPU] Begin implementing WebGPUTexture, WebGPUTextureView, and WebGPUTextureFormatEnum, and WebGPUSwapChain::configure upgrades : [Attachment 355163] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 19 14:54:26 PST 2018


Dean Jackson <dino at apple.com> has granted Justin Fan <justin_fan at apple.com>'s
request for review:
Bug 191794: [WebGPU] Begin implementing WebGPUTexture, WebGPUTextureView, and
WebGPUTextureFormatEnum, and WebGPUSwapChain::configure upgrades
https://bugs.webkit.org/show_bug.cgi?id=191794

Attachment 355163: Patch

https://bugs.webkit.org/attachment.cgi?id=355163&action=review




--- Comment #3 from Dean Jackson <dino at apple.com> ---
Comment on attachment 355163
  --> https://bugs.webkit.org/attachment.cgi?id=355163
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355163&action=review

> Source/WebCore/Modules/webgpu/GPUTextureFormatEnum.h:40
> +std::optional<PlatformTextureFormat>
convertAndValidate(GPUTextureFormatEnum);

I'm not sure I like this in the WebCore namespace. Do we need it in more than
one place? i.e. can it be file static?

It seems it is only used in GPUSwapChainMetal, so I think it can live there for
the moment.

> Source/WebCore/Modules/webgpu/WebGPUTextureFormatEnum.idl:33
> +    "R8G8B8A8Unorm",
> +    "R8G8B8A8Uint",
> +    "B8G8R8A8Unorm",
> +    "D32FloatS8Uint"

Ugh. I wonder if WebGPU should use better names here. Or maybe those are the
names everyone expects?


More information about the webkit-reviews mailing list