[webkit-reviews] review granted: [Bug 191575] Web Inspector: Styles: shift-clicking on a property should extend selection : [Attachment 354732] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 14 13:42:05 PST 2018


Devin Rousso <drousso at apple.com> has granted Nikita Vasilyev
<nvasilyev at apple.com>'s request for review:
Bug 191575: Web Inspector: Styles: shift-clicking on a property should extend
selection
https://bugs.webkit.org/show_bug.cgi?id=191575

Attachment 354732: Patch

https://bugs.webkit.org/attachment.cgi?id=354732&action=review




--- Comment #9 from Devin Rousso <drousso at apple.com> ---
Comment on attachment 354732
  --> https://bugs.webkit.org/attachment.cgi?id=354732
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=354732&action=review

r=me, with some design feedback/changes

>
Source/WebInspectorUI/UserInterface/Views/SpreadsheetCSSStyleDeclarationEditor.
js:57
> +    set focusIndex(value)

It seems odd that setting the `focusIndex` would automatically select
something.  I'd rather you extend/rework `selectProperties` to assume
`_anchorIndex` when not supplied, or just provide a way for callers to access
`_anchorIndex`.

>
Source/WebInspectorUI/UserInterface/Views/SpreadsheetCSSStyleDeclarationSection
.js:476
> +	   window.addEventListener("click",
this._handleWindowMouseUp.bind(this), {capture: true, once: true});

Please rename this to `_handleWindowClick`


More information about the webkit-reviews mailing list