[webkit-reviews] review granted: [Bug 191589] RTCPeerConnection.getTransceivers is not always exposing all transceivers : [Attachment 354673] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 13 10:30:02 PST 2018


Eric Carlson <eric.carlson at apple.com> has granted youenn fablet
<youennf at gmail.com>'s request for review:
Bug 191589: RTCPeerConnection.getTransceivers is not always exposing all
transceivers
https://bugs.webkit.org/show_bug.cgi?id=191589

Attachment 354673: Patch

https://bugs.webkit.org/attachment.cgi?id=354673&action=review




--- Comment #2 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 354673
  --> https://bugs.webkit.org/attachment.cgi?id=354673
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=354673&action=review

> Source/WebCore/Modules/mediastream/RTCPeerConnection.h:136
> +    const Vector<std::reference_wrapper<RTCRtpSender>>& getSenders() const;
> +    const Vector<std::reference_wrapper<RTCRtpReceiver>>& getReceivers()
const;
> +    const Vector<RefPtr<RTCRtpTransceiver>>& getTransceivers() const;
> +
> +    const Vector<std::reference_wrapper<RTCRtpSender>>& senders() const {
return m_transceiverSet->senders(); }
> +    const Vector<RefPtr<RTCRtpTransceiver>>& transceivers() const { return
m_transceiverSet->list(); }

It isn't at all clear why we have both getSenders() and senders(), and
getTransceivers() and transceivers(). Maybe "get" should be "collect", or
"senders" should be "cachedSenders"?


More information about the webkit-reviews mailing list