[webkit-reviews] review granted: [Bug 191107] Some minor X-Content-Type-Options parsing issues : [Attachment 353898] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 5 12:55:34 PST 2018


Darin Adler <darin at apple.com> has granted Rob Buis <rbuis at igalia.com>'s request
for review:
Bug 191107: Some minor X-Content-Type-Options parsing issues
https://bugs.webkit.org/show_bug.cgi?id=191107

Attachment 353898: Patch

https://bugs.webkit.org/attachment.cgi?id=353898&action=review




--- Comment #8 from Darin Adler <darin at apple.com> ---
Comment on attachment 353898
  --> https://bugs.webkit.org/attachment.cgi?id=353898
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=353898&action=review

> Source/WebCore/platform/network/HTTPParsers.cpp:477
> +inline bool isHTTPTabOrSpace(UChar character)

I’m not sure this helper function needs the word "HTTP" in it since it’s just
tab and space. Also seems like this function could be in the ASCIICType.h
header if it’s likely to come up often.

The "whitespace" functions elsewhere sometimes say HTML or HTTP because
whitespace has different meanings in different contexts so we are trying to
clarify which one. But "tab" and "space" aren’t so situational as far as I
know.

I suspect this could also just use the isHTTPSpace function (not sure I have
the name right) because the newline-related can’t possibly exist in the header
since it’s already been broken into lines, but not really sure.

Anyway, fine as is but would be nice to delete the "HTTP" and even nicer to not
have to define a function here because another happens to be available, either
in ASCIICType.h or in the header for other uses.


More information about the webkit-reviews mailing list