[webkit-reviews] review denied: [Bug 165072] [GTK] Difficult to read combo box text in dark theme : [Attachment 341720] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 31 23:56:46 PDT 2018


Carlos Garcia Campos <cgarcia at igalia.com> has denied Carlos Eduardo Ramalho
<cadubentzen at gmail.com>'s request for review:
Bug 165072: [GTK] Difficult to read combo box text in dark theme
https://bugs.webkit.org/show_bug.cgi?id=165072

Attachment 341720: Patch

https://bugs.webkit.org/attachment.cgi?id=341720&action=review




--- Comment #13 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 341720
  --> https://bugs.webkit.org/attachment.cgi?id=341720
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=341720&action=review

> Source/WebCore/rendering/RenderTheme.cpp:219
> +#if PLATFORM(GTK)
> +    case ListboxPart:
> +	   return adjustListboxStyle(styleResolver, style, element);
> +#endif

Do not use platform ifdefs here.

> Source/WebCore/rendering/RenderTheme.cpp:952
> +#if PLATFORM(GTK)
> +void RenderTheme::adjustListboxStyle(StyleResolver&, RenderStyle&, const
Element*) const
> +{
> +}
> +#endif

We could have a default empty implementation in the header for ports not
implementing this.

> Source/WebCore/rendering/RenderTheme.h:310
> +#if PLATFORM(GTK)
> +    virtual void adjustListboxStyle(StyleResolver&, RenderStyle&, const
Element*) const;
> +#endif

Remove the platform ifdefs here and simply use an empty implementation here
like other virtual methods do. I wouldn't make it const, even if it's true that
the gtk implementation is const.


More information about the webkit-reviews mailing list