[webkit-reviews] review granted: [Bug 185425] REGRESSION(r230743): Mousemove events are not coalesced properly, mousemove/drag is very laggy : [Attachment 339824] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 8 10:43:58 PDT 2018


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Brian Burg
<bburg at apple.com>'s request for review:
Bug 185425: REGRESSION(r230743): Mousemove events are not coalesced properly,
mousemove/drag is very laggy
https://bugs.webkit.org/show_bug.cgi?id=185425

Attachment 339824: Patch

https://bugs.webkit.org/attachment.cgi?id=339824&action=review




--- Comment #3 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 339824
  --> https://bugs.webkit.org/attachment.cgi?id=339824
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=339824&action=review

> Source/WebKit/UIProcess/WebPageProxy.cpp:1929
> +    bool lastQueuedEventWasAMouseMove = m_mouseEventQueue.size() > 1 &&
m_mouseEventQueue.last().type() == WebEvent::MouseMove;

Why not size() > 0 ?
I would call it lastQueuedEventWasMouseMove or do away with the variable
entirely.


More information about the webkit-reviews mailing list