[webkit-reviews] review granted: [Bug 184122] REGRESSION(r230035): ASSERT(MACH_PORT_VALID(m_sendPort)) hit in IPC::Connection::initializeSendSource() : [Attachment 336803] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 29 13:53:18 PDT 2018


Chris Dumez <cdumez at apple.com> has granted Brent Fulgham
<bfulgham at webkit.org>'s request for review:
Bug 184122: REGRESSION(r230035): ASSERT(MACH_PORT_VALID(m_sendPort)) hit in
IPC::Connection::initializeSendSource()
https://bugs.webkit.org/show_bug.cgi?id=184122

Attachment 336803: Patch

https://bugs.webkit.org/attachment.cgi?id=336803&action=review




--- Comment #9 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 336803
  --> https://bugs.webkit.org/attachment.cgi?id=336803
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=336803&action=review

> Source/WebKit/Platform/IPC/Connection.h:138
> +    static bool identifierIsDead(Identifier identifier) { return
identifier.port == MACH_PORT_DEAD; }

Do we ever need to distinguish null and dead? It does not look like it. If so,
could we rename identifierIsNull() to identifierIdValid() and have it use
MACH_PORT_VALID() internally?

> Source/WebKit/Platform/IPC/mac/ConnectionMac.mm:399
> +	   if (sendPort)

I do not think this check is useful, is it? We copied m_sendPort into sendPort
above and asserted that it was valid before that. There is no way for sendPort
to check after that since it is a copy.
If we want to be extra safe still, why not use if (MACH_PORT_VALID(sendPort)) ?


More information about the webkit-reviews mailing list