[webkit-reviews] review granted: [Bug 183593] [Nicosia] Add Cairo-specific GraphicsContext operation recorder : [Attachment 335691] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 15 01:18:31 PDT 2018


Carlos Garcia Campos <cgarcia at igalia.com> has granted Zan Dobersek
<zan at falconsigh.net>'s request for review:
Bug 183593: [Nicosia] Add Cairo-specific GraphicsContext operation recorder
https://bugs.webkit.org/show_bug.cgi?id=183593

Attachment 335691: Patch

https://bugs.webkit.org/attachment.cgi?id=335691&action=review




--- Comment #3 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 335691
  --> https://bugs.webkit.org/attachment.cgi?id=335691
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=335691&action=review

>
Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cp
p:41
> +PlatformContextCairo& getContext(PaintingOperationReplay& operationReplay)

I would rename this to platformContext() we don't use get in WebKit unless
using an out parameter for the return value.

>
Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cp
p:366
> +    UNUSED_PARAM(color);

Why don't you omit the name instead?

>
Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cp
p:510
> +    UNUSED_PARAM(fontSmoothing);

Same here.

>
Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cp
p:622
> +	       Cairo::drawLine(getContext(replayer), arg<0>(), arg<1>(),
arg<2>(), arg<3>(),
> +		   arg<4>(), arg<5>());

This could be one line


More information about the webkit-reviews mailing list