[webkit-reviews] review granted: [Bug 182731] [FTL] Add Arrayify for ArrayStorage and SlowPutArrayStorage : [Attachment 333775] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 19 18:36:23 PST 2018


Saam Barati <sbarati at apple.com> has granted Yusuke Suzuki
<utatane.tea at gmail.com>'s request for review:
Bug 182731: [FTL] Add Arrayify for ArrayStorage and SlowPutArrayStorage
https://bugs.webkit.org/show_bug.cgi?id=182731

Attachment 333775: Patch

https://bugs.webkit.org/attachment.cgi?id=333775&action=review




--- Comment #8 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 333775
  --> https://bugs.webkit.org/attachment.cgi?id=333775
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=333775&action=review

r=me with some FTL comments

> Source/JavaScriptCore/ftl/FTLLowerDFGToB3.cpp:14590
> +	       LValue shapeResult = m_out.belowOrEqual(

nit: I'd maybe call this something like "isExpectedShape" or
"isAnArrayStorageShape" or something similar.

> Source/JavaScriptCore/ftl/FTLLowerDFGToB3.cpp:14595
> +	       m_out.branch(shapeResult, usually(checkCase),
usually(falseCase));

these are both usually, that's wrong. The "falseCase" should be "unlikely"


More information about the webkit-reviews mailing list