[webkit-reviews] review granted: [Bug 182748] Allow specifying which plug-ins are supported : [Attachment 333911] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 16 11:32:51 PST 2018


Chris Dumez <cdumez at apple.com> has granted youenn fablet <youennf at gmail.com>'s
request for review:
Bug 182748: Allow specifying which plug-ins are supported
https://bugs.webkit.org/show_bug.cgi?id=182748

Attachment 333911: Patch

https://bugs.webkit.org/attachment.cgi?id=333911&action=review




--- Comment #16 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 333911
  --> https://bugs.webkit.org/attachment.cgi?id=333911
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=333911&action=review

r=me

> Source/WebCore/PAL/pal/SessionID.h:98
> +std::optional<SessionID> SessionID::decode(Decoder& decoder)

Please update the legacy coder to call this one if possible. This would avoid
code duplication.

> Source/WebCore/html/HTMLPlugInElement.cpp:408
> +	   document().addConsoleMessage(MessageSource::JS,
MessageLevel::Warning, ASCIILiteral("Tried to use an unsupported plugin."));

plug-in ?

>> Source/WebCore/platform/LocalizedStrings.cpp:665
>> +	return WEB_UI_STRING_KEY("Unsupported Plug-in", "Unsupported Plug-In",
"Label text to be used when an unsupported plug-in was blocked from loading");
> 
> Why does the key need to be different from the English here?

At least it is consistent with Blocked Plug-in above.

> Source/WebKit/Platform/IPC/ArgumentCoders.h:429
> +    static std::optional<HashSetType> decode(Decoder& decoder)

Please update the legacy coder to call this one if possible. This would avoid
code duplication.


More information about the webkit-reviews mailing list