[webkit-reviews] review granted: [Bug 193049] Move WKEditCommandObjC and WKEditorUndoTargetObjC into a separate file : [Attachment 358121] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 28 17:12:04 PST 2018


Sam Weinig <sam at webkit.org> has granted Wenson Hsieh <wenson_hsieh at apple.com>'s
request for review:
Bug 193049: Move WKEditCommandObjC and WKEditorUndoTargetObjC into a separate
file
https://bugs.webkit.org/show_bug.cgi?id=193049

Attachment 358121: Patch

https://bugs.webkit.org/attachment.cgi?id=358121&action=review




--- Comment #2 from Sam Weinig <sam at webkit.org> ---
Comment on attachment 358121
  --> https://bugs.webkit.org/attachment.cgi?id=358121
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=358121&action=review

> Source/WebKit/ChangeLog:15
> +	   Rename WKEditCommandObjC to WKEditCommand, and WKEditorUndoTarget to
WKEditorUndoTargetObjC. The ObjC suffix in

Looks like you have this phrase backwards: "WKEditorUndoTarget to
WKEditorUndoTargetObjC".

> Source/WebKit/UIProcess/Cocoa/WKEditCommand.h:36
> +    RefPtr<WebKit::WebEditCommandProxy> m_command;

This member should go in the implementation file.

> Source/WebKit/UIProcess/Cocoa/WKEditCommand.h:38
> +-
(instancetype)initWithWebEditCommandProxy:(Ref<WebKit::WebEditCommandProxy>&&)c
ommand;

I think you probably also want something like:
- (instancetype)init NS_UNAVAILABLE;

> Source/WebKit/UIProcess/Cocoa/WKEditCommand.h:39
> +- (WebKit::WebEditCommandProxy*)command;

Can this ever be null? If not, return a reference?

> Source/WebKit/UIProcess/Cocoa/WKEditCommand.h:45
> + at interface WKEditorUndoTarget : NSObject
> +- (void)undoEditing:(id)sender;
> +- (void)redoEditing:(id)sender;
> + at end

My instinct is that this should have it's own file, but it is very closely tied
to WKEditCommand. Perhaps a comment explaining why it's here would help.


More information about the webkit-reviews mailing list