[webkit-reviews] review granted: [Bug 192855] [GTK][WPE] Unify TestController::platformRunUntil() and honor condition flag : [Attachment 357712] Patch v2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 19 14:48:56 PST 2018


Michael Catanzaro <mcatanzaro at igalia.com> has granted Adrian Perez
<aperez at igalia.com>'s request for review:
Bug 192855: [GTK][WPE] Unify TestController::platformRunUntil() and honor
condition flag
https://bugs.webkit.org/show_bug.cgi?id=192855

Attachment 357712: Patch v2

https://bugs.webkit.org/attachment.cgi?id=357712&action=review




--- Comment #9 from Michael Catanzaro <mcatanzaro at igalia.com> ---
Comment on attachment 357712
  --> https://bugs.webkit.org/attachment.cgi?id=357712
Patch v2

View in context: https://bugs.webkit.org/attachment.cgi?id=357712&action=review

OK, you're right.

> Tools/WebKitTestRunner/gtk/TestControllerGtk.cpp:79
> +    while (!(done | timeoutTimer.timedOut))

PROBLEM: you meant to write || here in TestControllerGTK.cpp.

> Tools/WebKitTestRunner/wpe/TestControllerWPE.cpp:82
> +    while (!(done || timeoutTimer.timedOut))

Personally I would write: while (!done && !timeoutTimer.timedOut). One fewer
level of parentheses, a bit easier to read IMO. Up to you.


More information about the webkit-reviews mailing list