[webkit-reviews] review granted: [Bug 192288] Merge parseAccessControlExposeHeadersAllowList into parseAccessControlAllowList : [Attachment 356339] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 4 07:39:38 PST 2018


Frédéric Wang (:fredw) <fred.wang at free.fr> has granted Rob Buis
<rbuis at igalia.com>'s request for review:
Bug 192288: Merge parseAccessControlExposeHeadersAllowList into
parseAccessControlAllowList
https://bugs.webkit.org/show_bug.cgi?id=192288

Attachment 356339: Patch

https://bugs.webkit.org/attachment.cgi?id=356339&action=review




--- Comment #2 from Frédéric Wang (:fredw) <fred.wang at free.fr> ---
Comment on attachment 356339
  --> https://bugs.webkit.org/attachment.cgi?id=356339
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=356339&action=review

> Source/WebCore/platform/network/HTTPParsers.h:-167
> -    return set;

parseAccessControlAllowList + addToAccessControlAllowList are less readable
than parseAccessControlExposeHeadersAllowList as they try to avoid creating
unnecessary substrings. I think you can rewrite this in a more concise way
using StringViews:

String::split(UChar separator, const SplitFunctor& functor)
StringView::stripLeadingAndTrailingMatchedCharacters
StringView::isEmpty()


More information about the webkit-reviews mailing list