[webkit-reviews] review granted: [Bug 192069] Implement non-timeslice mode encoding for MediaRecorder : [Attachment 356244] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Dec 1 15:20:46 PST 2018


Eric Carlson <eric.carlson at apple.com> has granted Wendy <yuhan_wu at apple.com>'s
request for review:
Bug 192069: Implement non-timeslice mode encoding for MediaRecorder
https://bugs.webkit.org/show_bug.cgi?id=192069

Attachment 356244: Patch

https://bugs.webkit.org/attachment.cgi?id=356244&action=review




--- Comment #24 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 356244
  --> https://bugs.webkit.org/attachment.cgi?id=356244
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=356244&action=review

> Source/WebCore/platform/mediarecorder/MediaRecorderPrivateAVImpl.cpp:27
> +#include "MediaRecorderPrivateAVImpl.h"

Nit: these files should be called MediaRecorderPrivateAVFImpl (missing the
"F").

>
Source/WebCore/platform/mediarecorder/cocoa/MediaRecorderPrivateWriterCocoa.mm:
165
> +	   CMTime startTime = CMClockGetTime(CMClockGetHostTimeClock());
> +	   [m_writer startSessionAtSourceTime:startTime];

Nit: you don't need the temporary "startTime" variable here.


More information about the webkit-reviews mailing list