[webkit-reviews] review granted: [Bug 189114] Long press on picture/link show menu obscured by keyboard : [Attachment 348447] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 29 17:44:48 PDT 2018


Megan Gardner <megan_gardner at apple.com> has granted James Savage
<james.savage at apple.com>'s request for review:
Bug 189114: Long press on picture/link show menu obscured by keyboard
https://bugs.webkit.org/show_bug.cgi?id=189114

Attachment 348447: Patch

https://bugs.webkit.org/attachment.cgi?id=348447&action=review




--- Comment #2 from Megan Gardner <megan_gardner at apple.com> ---
Comment on attachment 348447
  --> https://bugs.webkit.org/attachment.cgi?id=348447
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=348447&action=review

r=me, with comments.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:373
> +	   CGRect visibleRect = CGRectNull;

See associated next comment.
I think this should be view.window.bounds (or equivalent) not CGRectNull.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:402
>  {

Probably rename this to something better if we make the associated changes.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:411
> +	   visibleRect = view.window.bounds;

Could we move this logic to the calling function? I don't like having to do
this compare here, if we just set the visible rect to the default before we
even call into here, then we can make this cleaner.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:414
> +

remove whitespace

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:549
> +    CGRect visibleRect = CGRectNull;

Same as above. Should be view.window.bounds


More information about the webkit-reviews mailing list