[webkit-reviews] review granted: [Bug 177468] Web Inspector: Improve Table scrolling performance : [Attachment 321752] [PATCH] Proposed Fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 26 11:01:07 PDT 2017


Brian Burg <bburg at apple.com> has granted Joseph Pecoraro <joepeck at webkit.org>'s
request for review:
Bug 177468: Web Inspector: Improve Table scrolling performance
https://bugs.webkit.org/show_bug.cgi?id=177468

Attachment 321752: [PATCH] Proposed Fix

https://bugs.webkit.org/attachment.cgi?id=321752&action=review




--- Comment #3 from Brian Burg <bburg at apple.com> ---
Comment on attachment 321752
  --> https://bugs.webkit.org/attachment.cgi?id=321752
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=321752&action=review

r=me

> Source/WebInspectorUI/UserInterface/Views/Table.js:671
> +	   let availableHeight = this._cachedHeight;

I'm not sure about usage of these locals. Can you get rid of them, or uses them
instead of the member after this point?

> Source/WebInspectorUI/UserInterface/Views/Table.js:968
> +	       if (row.__widthGeneration !== this._widthsGeneration && row !==
this._fillerRow) {

In the interest of reducing indent, can you make this an early continue if
there's nothing to do?

> Source/WebInspectorUI/UserInterface/Views/Table.js:973
> +		   row.__widthGeneration = this._widthsGeneration;

It bothers me that widthGeneration and widthsGeneration are spelled
differently. Do they need to differ?


More information about the webkit-reviews mailing list