[webkit-reviews] review granted: [Bug 177255] Add infrastructure for adding custom headers to requests per website : [Attachment 321340] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 20 15:50:32 PDT 2017


Geoffrey Garen <ggaren at apple.com> has granted Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 177255: Add infrastructure for adding custom headers to requests per
website
https://bugs.webkit.org/show_bug.cgi?id=177255

Attachment 321340: Patch

https://bugs.webkit.org/attachment.cgi?id=321340&action=review




--- Comment #3 from Geoffrey Garen <ggaren at apple.com> ---
Comment on attachment 321340
  --> https://bugs.webkit.org/attachment.cgi?id=321340
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=321340&action=review

r=me

> Source/WebKit/UIProcess/API/C/WKWebsitePolicies.h:55
> +WK_EXPORT WKArrayRef
WKWebsitePoliciesCopyAdditionalCustomHeaderFields(WKWebsitePoliciesRef);
> +WK_EXPORT void
WKWebsitePoliciesSetAdditionalCustomHeaderFields(WKWebsitePoliciesRef,
WKArrayRef);

I think you can just call these "CustomHeaderFields" rather than
"AdditionalCustomHeaderFields". Being custom is more specific than being
additional.


More information about the webkit-reviews mailing list