[webkit-reviews] review granted: [Bug 178720] [GTK][WPE] Switch to use API::NavigationClient : [Attachment 324800] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 26 12:17:01 PDT 2017


Alex Christensen <achristensen at apple.com> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 178720: [GTK][WPE] Switch to use API::NavigationClient
https://bugs.webkit.org/show_bug.cgi?id=178720

Attachment 324800: Patch

https://bugs.webkit.org/attachment.cgi?id=324800&action=review




--- Comment #6 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 324800
  --> https://bugs.webkit.org/attachment.cgi?id=324800
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=324800&action=review

> Source/WebKit/UIProcess/API/APINavigationAction.h:44
> +    static Ref<NavigationAction> create(WebKit::NavigationActionData&&
navigationActionData, API::FrameInfo* sourceFrame, std::optional<WTF::String>
targetFrameName, WebCore::ResourceRequest&& request, bool shouldOpenAppLinks,
RefPtr<UserInitiatedAction>&& userInitiatedAction)

I think we should just have one create function.

> Source/WebKit/UIProcess/API/APINavigationAction.h:85
> +    std::optional<WTF::String> m_targetFrameName;

Could we have a null string meaning there's no frame name instead of an
optional string?


More information about the webkit-reviews mailing list