[webkit-reviews] review granted: [Bug 178181] [iOS] Conditionally rename DatabaseProcess to StorageProcess when building for iOS devices : [Attachment 323492] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 11 22:52:23 PDT 2017


mitz at webkit.org has granted Andy Estes <aestes at apple.com>'s request for review:
Bug 178181: [iOS] Conditionally rename DatabaseProcess to StorageProcess when
building for iOS devices
https://bugs.webkit.org/show_bug.cgi?id=178181

Attachment 323492: Patch

https://bugs.webkit.org/attachment.cgi?id=323492&action=review




--- Comment #4 from mitz at webkit.org ---
Comment on attachment 323492
  --> https://bugs.webkit.org/attachment.cgi?id=323492
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=323492&action=review

> Source/WebKit/Configurations/BaseTarget.xcconfig:120
> +WK_STORAGE_SERVICE_PRODUCT_NAME = com.apple.WebKit.Storage;
> +WK_STORAGE_SERVICE_PRODUCT_NAME[sdk=iphoneos11*] =
$(WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11$(IPHONEOS_DEPLOYMENT_TARGET:suffi
x:identifier));
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_0 = com.apple.WebKit.Databases;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_1 = com.apple.WebKit.Databases;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_2 = com.apple.WebKit.Databases;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_3 = com.apple.WebKit.Storage;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_4 = com.apple.WebKit.Storage;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_5 = com.apple.WebKit.Storage;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_6 = com.apple.WebKit.Storage;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_7 = com.apple.WebKit.Storage;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_8 = com.apple.WebKit.Storage;
> +WK_STORAGE_SERVICE_PRODUCT_NAME_IPHONEOS_11_9 = com.apple.WebKit.Storage;

This can be written slightly more succinctly by enumerating just the
exceptional cases. Something along the lines of (typed here without testing):

WK_STORAGE_SERVICE_PRODUCT_NAME =
$(WK_STORAGE_SERVICE_PRODUCT_NAME_$(WK_USE_LEGACY_STORAGE_SERVICE_NAME));
WK_STORAGE_SERVICE_PRODUCT_NAME_ = $(WK_STORAGE_SERVICE_PRODUCT_NAME_NO);
WK_STORAGE_SERVICE_PRODUCT_NAME_NO = com.apple.WebKit.Storage;
WK_STORAGE_SERVICE_PRODUCT_NAME_YES = com.apple.WebKit.Databases;

WK_USE_LEGACY_STORAGE_SERVICE_NAME[sdk=iphoneos11*] =
$(WK_USE_LEGACY_STORAGE_SERVICE_NAME_$(IPHONEOS_DEPLOYMENT_TARGET:suffix:identi
fier));
WK_USE_LEGACY_STORAGE_SERVICE_NAME_11_0 = YES;
WK_USE_LEGACY_STORAGE_SERVICE_NAME_11_1 = YES;
WK_USE_LEGACY_STORAGE_SERVICE_NAME_11_2 = YES;


More information about the webkit-reviews mailing list