[webkit-reviews] review granted: [Bug 175890] Image data should be coalesced if it comes in small chunks before updating the ImageSource : [Attachment 322264] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 9 10:04:42 PDT 2017


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Said Abou-Hallawa
<sabouhallawa at apple.com>'s request for review:
Bug 175890: Image data should be coalesced if it comes in small chunks before
updating the ImageSource
https://bugs.webkit.org/show_bug.cgi?id=175890

Attachment 322264: Patch

https://bugs.webkit.org/attachment.cgi?id=322264&action=review




--- Comment #18 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 322264
  --> https://bugs.webkit.org/attachment.cgi?id=322264
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=322264&action=review

> Source/WebCore/loader/cache/CachedImage.cpp:411
> +void CachedImage::doUpdateBuffer(SharedBuffer& data)

This name is awkward. Maybe updateBufferInternal?

> Source/WebCore/loader/cache/CachedImage.cpp:421
> +    if (shouldDeferUpdateImageData())
> +	   return;
> +    
>      // Have the image update its data from its internal buffer.
>      // It will not do anything now, but will delay decoding until

The early return after shouldDeferUpdateImageData() and then the comment which
says "It will not do anything now" are confusing. If updateImageData don't do
anything, why did we early return?


More information about the webkit-reviews mailing list