[webkit-reviews] review granted: [Bug 177943] [GTK][WPE] Add API to configure and enable resource load statistics : [Attachment 322837] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 5 09:20:13 PDT 2017


Michael Catanzaro <mcatanzaro at igalia.com> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 177943: [GTK][WPE] Add API to configure and enable resource load statistics
https://bugs.webkit.org/show_bug.cgi?id=177943

Attachment 322837: Patch

https://bugs.webkit.org/attachment.cgi?id=322837&action=review




--- Comment #3 from Michael Catanzaro <mcatanzaro at igalia.com> ---
Comment on attachment 322837
  --> https://bugs.webkit.org/attachment.cgi?id=322837
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=322837&action=review

You'll add an Ephy preference too?

> Source/WebKit/UIProcess/API/glib/WebKitWebContext.cpp:313
> +    configuration.resourceLoadStatisticsDirectory =
processPoolconfigurarion.resourceLoadStatisticsDirectory();

You should rename it to processPoolConfiguration in a follow-up.

> Source/WebKit/UIProcess/API/glib/WebKitWebContext.cpp:336
> +	  
configuration.setResourceLoadStatisticsDirectory(WebCore::stringFromFileSystemR
epresentation(webkit_website_data_manager_get_resource_load_stats_directory(pri
v->websiteDataManager.get())));

I know I approved this earlier, and you probably won't like me taking it back,
but seeing it written out, it just doesn't feel as nice as and professional as
webkit_website_data_manager_get_resource_load_statistics_directory(). I don't
think it's a problem that the function name is a bit long.

> Source/WebKit/UIProcess/API/glib/WebKitWebsiteDataManager.cpp:87
> +    PROP_RESOURCE_LOAD_STATS_DIRECTORY,

...so I'd prefer to write it out as STATISTICS everywhere.


More information about the webkit-reviews mailing list