[webkit-reviews] review granted: [Bug 177641] Web Inspector: Include Beacon and Ping requests in Network tab : [Attachment 322395] [PATCH] Proposed Fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 2 11:42:31 PDT 2017


Chris Dumez <cdumez at apple.com> has granted Joseph Pecoraro
<joepeck at webkit.org>'s request for review:
Bug 177641: Web Inspector: Include Beacon and Ping requests in Network tab
https://bugs.webkit.org/show_bug.cgi?id=177641

Attachment 322395: [PATCH] Proposed Fix

https://bugs.webkit.org/attachment.cgi?id=322395&action=review




--- Comment #47 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 322395
  --> https://bugs.webkit.org/attachment.cgi?id=322395
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=322395&action=review

r=me with suggestions.

> Source/WebCore/inspector/InspectorNetworkAgent.cpp:368
> +    Inspector::Protocol::Page::ResourceType protocolResourceType =
InspectorPageAgent::resourceTypeJson(type);

auto ?

> Source/WebCore/inspector/InspectorPageAgent.cpp:278
> +InspectorPageAgent::ResourceType
InspectorPageAgent::cachedResourceType(CachedResource::Type type)

Method is confusingly named since it does not return a CachedResource::Type?
Maybe it should be named inspectorResourceType() ?

> Source/WebCore/loader/LoaderStrategy.h:68
> +    using PingLoadCompletionHandler = WTF::Function<void(const
ResourceError&, const ResourceResponse&)>;

The parameters are mutually exclusive it seems. This should probably be a
WTF::Expected<ResourceRespnse, ResourceError> instead.

> Source/WebKit/NetworkProcess/PingLoad.cpp:80
> +void PingLoad::didFinish(const ResourceError& error, const ResourceResponse&
response)

The parameters are mutually exclusive it seems. This should probably be a
WTF::Expected<ResourceRespnse, ResourceError> instead.

> Source/WebKit/NetworkProcess/PingLoad.h:85
> +    WTF::CompletionHandler<void(const WebCore::ResourceError&, const
WebCore::ResourceResponse&)> m_completionHandler;

The parameters are mutually exclusive it seems. This should probably be a
WTF::Expected<ResourceRespnse, ResourceError> instead.


More information about the webkit-reviews mailing list