[webkit-reviews] review granted: [Bug 179621] webkitpy: Better name-version mapping : [Attachment 327644] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 27 10:32:02 PST 2017


David Kilzer (:ddkilzer) <ddkilzer at webkit.org> has granted Jonathan Bedard
<jbedard at apple.com>'s request for review:
Bug 179621: webkitpy: Better name-version mapping
https://bugs.webkit.org/show_bug.cgi?id=179621

Attachment 327644: Patch

https://bugs.webkit.org/attachment.cgi?id=327644&action=review




--- Comment #23 from David Kilzer (:ddkilzer) <ddkilzer at webkit.org> ---
Comment on attachment 327644
  --> https://bugs.webkit.org/attachment.cgi?id=327644
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=327644&action=review

r=me if all bots pass with this patch.

> Tools/Scripts/webkitpy/common/system/platforminfo.py:62
> -	   if self.os_name == 'freebsd' or self.os_name == 'openbsd' or
self.os_name == 'netbsd' or self.os_name == 'ios':
> -	       self.os_version = platform_module.release()
> +	   self.os_version = None
> +
>	   if self.os_name.startswith('mac'):
> -	       self.os_version =
self._determine_mac_version(Version(platform_module.mac_ver()[0]))
> -	   if self.os_name.startswith('win'):
> -	       self.os_version =
self._determine_win_version(self._win_version(sys_module))
> +	       version = Version(platform_module.mac_ver()[0])
> +	   elif self.os_name.startswith('win'):
> +	       version = self._win_version(sys_module)
> +	   elif self.os_name == 'freebsd':
> +	       version = platform_module.release().split('-')[0]

This removes support for 'openbsd' and 'netbsd'.  Will anyone care?  I suppose
it depends on whether anyone is running WebKit tests on those platforms.


More information about the webkit-reviews mailing list