[webkit-reviews] review granted: [Bug 179693] Add some X86 intrinsics to $vm to help with some perf testing : [Attachment 327047] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 15 19:47:17 PST 2017


Mark Lam <mark.lam at apple.com> has granted Saam Barati <sbarati at apple.com>'s
request for review:
Bug 179693: Add some X86 intrinsics to $vm to help with some perf testing
https://bugs.webkit.org/show_bug.cgi?id=179693

Attachment 327047: patch

https://bugs.webkit.org/attachment.cgi?id=327047&action=review




--- Comment #3 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 327047
  --> https://bugs.webkit.org/attachment.cgi?id=327047
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=327047&action=review

r=me

> Source/JavaScriptCore/tools/JSDollarVM.cpp:150
> +    return JSValue::encode(jsBoolean(false));

Need to add UNUSED_PARAM(exec) to placate the other builds here.

> Source/JavaScriptCore/tools/JSDollarVM.cpp:367
> +    putDirectNativeFunction(vm, globalObject, Identifier::fromString(&vm,
"CPUMfence"), 0,
> +	   functionCPUMfence, CPUMfenceIntrinsic, 0);

nit: why not prefix the JS function name with lower case "cpu" instead of
"CPU"?	I think starting with lower case is more consistent with WebKit
convention.  Ditto for the others below as well.


More information about the webkit-reviews mailing list