[webkit-reviews] review granted: [Bug 179404] Implement ServiceWorker handle fetch for navigation loads : [Attachment 326846] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 14 11:40:49 PST 2017


Alex Christensen <achristensen at apple.com> has granted youenn fablet
<youennf at gmail.com>'s request for review:
Bug 179404: Implement ServiceWorker handle fetch for navigation loads
https://bugs.webkit.org/show_bug.cgi?id=179404

Attachment 326846: Patch

https://bugs.webkit.org/attachment.cgi?id=326846&action=review




--- Comment #57 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 326846
  --> https://bugs.webkit.org/attachment.cgi?id=326846
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=326846&action=review

> Source/WebCore/loader/DocumentLoader.h:313
> +    void doLoadingMainResource(ResourceRequest&&);

I think this should be named loadMainResource or startLoadingMainResource.

> Source/WebCore/loader/DocumentThreadableLoader.cpp:-331
> -	   ASSERT(response.type() == ResourceResponse::Type::Opaqueredirect);

We should rename Opaqueredirect to OpaqueRedirect.


More information about the webkit-reviews mailing list