[webkit-reviews] review granted: [Bug 179290] Move code that maps a CompositeOperator and BlendMode to a CGBlendMode into a helper function : [Attachment 326057] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Nov 4 19:35:17 PDT 2017


Darin Adler <darin at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 179290: Move code that maps a CompositeOperator and BlendMode to a
CGBlendMode into a helper function
https://bugs.webkit.org/show_bug.cgi?id=179290

Attachment 326057: Patch

https://bugs.webkit.org/attachment.cgi?id=326057&action=review




--- Comment #4 from Darin Adler <darin at apple.com> ---
Comment on attachment 326057
  --> https://bugs.webkit.org/attachment.cgi?id=326057
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=326057&action=review

> Source/WebCore/platform/graphics/cg/GraphicsContextCG.cpp:140
> +static CGBlendMode compositeAndBlendToCGBlendMode(CompositeOperator
compositeOperator, BlendMode blendMode)

Since this is C++ I don’t think we really need to restate what the arguments
are in the function name. I think this should be called something like
selectCGBlendMode.

I think it’s a little strange that it ignores the composite operator when the
blend mode is something other than normal. It’s hard to understand why that’s
OK. I’m sure there is a good reason. I would love to have a comment explaining
it.


More information about the webkit-reviews mailing list