[webkit-reviews] review granted: [Bug 179206] RenderObject::*positioned() naming cleanup : [Attachment 325788] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 3 07:42:30 PDT 2017


Darin Adler <darin at apple.com> has granted zalan <zalan at apple.com>'s request for
review:
Bug 179206: RenderObject::*positioned() naming cleanup
https://bugs.webkit.org/show_bug.cgi?id=179206

Attachment 325788: Patch

https://bugs.webkit.org/attachment.cgi?id=325788&action=review




--- Comment #3 from Darin Adler <darin at apple.com> ---
Comment on attachment 325788
  --> https://bugs.webkit.org/attachment.cgi?id=325788
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=325788&action=review

> Source/WebCore/rendering/RenderObject.h:421
> +    bool isAbsolutePositioned() const { return isOutOfFlowPositioned() &&
style().position() == AbsolutePosition; }

The CSS specification calls this "is absolutely positioned", not "is absolute
positioned", and I think the former is better grammar.

> Source/WebCore/rendering/RenderObject.h:422
> +    bool isRelativePositioned() const { return
m_bitfields.isRelativePositioned(); }

The CSS specification calls this "is relatively positioned", as opposed to "is
relative positioned", and I think the former is better grammar.

> Source/WebCore/rendering/RenderObject.h:423
>      bool isStickyPositioned() const { return
m_bitfields.isStickyPositioned(); }

The CSS specification calls this "is stickily positioned", as opposed to "is
sticky positioned", and I think the former is better grammar.

> Source/WebCore/rendering/RenderObject.h:859
> -	       IsStaticallyPositioned = 0,
> -	       IsRelativelyPositioned = 1,
> +	       IsStaticPositioned = 0,
> +	       IsRelativePositioned = 1,

I think the old names here are better than the new ones, grammatically
speaking.


More information about the webkit-reviews mailing list