[webkit-reviews] review granted: [Bug 170864] [CG] To decode an image frame asynchronously, pass the native size of the image to CGImageSourceCreateThumbnailAtIndex() if it's smaller than the sizeForDrawing : [Attachment 309381] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 8 12:56:20 PDT 2017


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Said Abou-Hallawa
<sabouhallawa at apple.com>'s request for review:
Bug 170864: [CG] To decode an image frame asynchronously, pass the native size
of the image to CGImageSourceCreateThumbnailAtIndex() if it's smaller than the
sizeForDrawing
https://bugs.webkit.org/show_bug.cgi?id=170864

Attachment 309381: Patch

https://bugs.webkit.org/attachment.cgi?id=309381&action=review




--- Comment #23 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 309381
  --> https://bugs.webkit.org/attachment.cgi?id=309381
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=309381&action=review

> Source/WebCore/platform/graphics/cg/ImageDecoderCG.cpp:89
> +    unsigned maxPixelSize = DecodingOptions::maxDimension(sizeForDrawing);

maxPixelSize sounds like area, but it's now just one dimension? Could use a
better name.

> Source/WebCore/platform/graphics/cg/ImageDecoderCG.cpp:411
> +	   // CGImageSourceCreateThumbnailAtIndex() returns a CGImage with the
image native size
> +	   // regardless of the subsamplingLevel. So we need to get the image
native size for
> +	   // SubsamplingLevel::Default and then compare it with
sizeForDrawing.

I'm not sure I understand this comment.


More information about the webkit-reviews mailing list