[webkit-reviews] review granted: [Bug 171672] MediaSource.readyState should use an IDL enum : [Attachment 309147] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 5 08:02:32 PDT 2017


Eric Carlson <eric.carlson at apple.com> has granted Nael Ouedraogo
<nael.ouedp at gmail.com>'s request for review:
Bug 171672: MediaSource.readyState should use an IDL enum
https://bugs.webkit.org/show_bug.cgi?id=171672

Attachment 309147: Patch

https://bugs.webkit.org/attachment.cgi?id=309147&action=review




--- Comment #2 from Eric Carlson <eric.carlson at apple.com> ---
Comment on attachment 309147
  --> https://bugs.webkit.org/attachment.cgi?id=309147
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=309147&action=review

> Source/WebCore/Modules/mediasource/MediaSource.cpp:56
> +static const char* dumpReadyState(WebCore::MediaSource::ReadyState
readyState)

Nit: "dumpReadyState" doesn't describe what this function does. Maybe
"toString" instead?

> Source/WebCore/Modules/mediasource/MediaSource.cpp:61
> +    case WebCore::MediaSource::ReadyState::Closed: return "closed";
> +    case WebCore::MediaSource::ReadyState::Ended: return "ended";
> +    case WebCore::MediaSource::ReadyState::Open: return "open";

Nit: I think having the "return" on the same line as the "case" makes these
slightly harder to read.

> Source/WebCore/Modules/mediasource/MediaSource.cpp:528
> +    ReadyState oldState = readyState();

Nit: "auto" please.


More information about the webkit-reviews mailing list