[webkit-reviews] review granted: [Bug 170206] webkitpy: Add IOSDevicePort and IOSPort tests : [Attachment 305647] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 28 16:27:41 PDT 2017


Alexey Proskuryakov <ap at webkit.org> has granted Jonathan Bedard
<jbedard at apple.com>'s request for review:
Bug 170206: webkitpy: Add IOSDevicePort and IOSPort tests
https://bugs.webkit.org/show_bug.cgi?id=170206

Attachment 305647: Patch

https://bugs.webkit.org/attachment.cgi?id=305647&action=review




--- Comment #3 from Alexey Proskuryakov <ap at webkit.org> ---
Comment on attachment 305647
  --> https://bugs.webkit.org/attachment.cgi?id=305647
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=305647&action=review

r=me, please fix class naming.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:27
> +class iosDeviceTest(ios_testcase.iOSTest):

Although there is one test class named like this, the WebKit style calls for
"IOSDeviceTest" as the name. Most iOS classes in webkitpy follow the style.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:28
> +    os_name = 'ios-device'

This shows a shortcoming in the code - the OS name is iOS, not iOS Device.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:31
> +    port_maker = IOSDevicePort

Maker is a strange name, there is no pattern like this that I'm aware of.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:32
> +    is_simulator = True

Wut?

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:36
> +	   port.set_option('child_processes', 1)

This is worth explaining if it's needed (is it?)

> Tools/Scripts/webkitpy/port/ios_simulator_unittest.py:32
> +class iosSimulatorTest(ios_testcase.iOSTest):

Ditto w.r.t. naming.


More information about the webkit-reviews mailing list