[webkit-reviews] review granted: [Bug 173721] REGRESSION (r218419): 7 leaks in PluginLoadClientPolicies.mm : [Attachment 313646] Patch v2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 22 11:56:51 PDT 2017


Joseph Pecoraro <joepeck at webkit.org> has granted David Kilzer (:ddkilzer)
<ddkilzer at webkit.org>'s request for review:
Bug 173721: REGRESSION (r218419): 7 leaks in PluginLoadClientPolicies.mm
https://bugs.webkit.org/show_bug.cgi?id=173721

Attachment 313646: Patch v2

https://bugs.webkit.org/attachment.cgi?id=313646&action=review




--- Comment #3 from Joseph Pecoraro <joepeck at webkit.org> ---
Comment on attachment 313646
  --> https://bugs.webkit.org/attachment.cgi?id=313646
Patch v2

View in context: https://bugs.webkit.org/attachment.cgi?id=313646&action=review

> Tools/TestWebKitAPI/Tests/WebKit2Cocoa/PluginLoadClientPolicies.mm:71
> +    RetainPtr<NSMutableDictionary> newPolicies = adoptNS([policies
mutableCopy]);

r=me, but I find this way harder to read.

How about switching to ObjC literal syntax? You'd end up with something like:

    RetainPtr<NSMutableDictionary> newPolicies = adoptNS([policies
mutableCopy]);
    [newPolicies removeObjectForKey:@"apple.com"];
    newPolicies.get()[@"google.com"] = @{
	@"com.macromedia.Flash Player.plugin": @{
	    @"26.0.0.126": @(kWKPluginLoadClientPolicyAllowAlways),
	},
	@"com.apple.QuickTime.plugin": @{
	    @"1.0": @(kWKPluginLoadClientPolicyBlock),
	    @"1.1": @(kWKPluginLoadClientPolicyAllow),
	},
    };


More information about the webkit-reviews mailing list