[webkit-reviews] review granted: [Bug 173327] Web Inspector: Send context attributes for tracked canvases : [Attachment 313375] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 20 14:02:48 PDT 2017


Joseph Pecoraro <joepeck at webkit.org> has granted Devin Rousso
<drousso at apple.com>'s request for review:
Bug 173327: Web Inspector: Send context attributes for tracked canvases
https://bugs.webkit.org/show_bug.cgi?id=173327

Attachment 313375: Patch

https://bugs.webkit.org/attachment.cgi?id=313375&action=review




--- Comment #4 from Joseph Pecoraro <joepeck at webkit.org> ---
Comment on attachment 313375
  --> https://bugs.webkit.org/attachment.cgi?id=313375
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=313375&action=review

> LayoutTests/inspector/canvas/context-attributes-expected.txt:13
>
+{"alpha":true,"depth":true,"stencil":false,"antialias":true,"premultipliedAlph
a":true,"preserveDrawingBuffer":false,"failIfMajorPerformanceCaveat":false}

We could JSON.stringify(obj, null, 2) to make this easier to read.

> Source/WebInspectorUI/UserInterface/Views/CanvasDetailsSidebarPanel.js:221
> +	       const columns = {
> +		   name: {title: WebInspector.UIString("Name")},
> +		   value: {title: WebInspector.UIString("Value"), width:
"30%"},
> +	       };
> +	       dataGrid = this._attributesDataGridRow.dataGrid = new
WebInspector.DataGrid(columns);

Style: Again I think we should inline these as the last param. It looks very
awkward like this!


More information about the webkit-reviews mailing list