[webkit-reviews] review granted: [Bug 172908] Fix MediaPlayerPrivateMediaFoundation::naturalSize : [Attachment 311972] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 5 07:10:23 PDT 2017


Alex Christensen <achristensen at apple.com> has granted Konstantin Tokarev
<annulen at yandex.ru>'s request for review:
Bug 172908: Fix MediaPlayerPrivateMediaFoundation::naturalSize
https://bugs.webkit.org/show_bug.cgi?id=172908

Attachment 311972: Patch

https://bugs.webkit.org/attachment.cgi?id=311972&action=review




--- Comment #2 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 311972
  --> https://bugs.webkit.org/attachment.cgi?id=311972
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=311972&action=review

>
Source/WebCore/platform/graphics/win/MediaPlayerPrivateMediaFoundation.cpp:1563
> +	   FloatSize size(width, height);
> +	   size.setWidth(size.width() * parNumerator / parDenominator);
> +	   return size;

Can't we just return FloatSize(width * parNumerator / parDenominator, height)?
Also, parNumerator and parDenominator could have better names.


More information about the webkit-reviews mailing list