[webkit-reviews] review granted: [Bug 173450] Use WTFLogAlways for debug logging so that it shows up in device system logs : [Attachment 314739] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 6 12:05:34 PDT 2017


Simon Fraser (smfr) <simon.fraser at apple.com> has granted zalan
<zalan at apple.com>'s request for review:
Bug 173450: Use WTFLogAlways for debug logging so that it shows up in device
system logs
https://bugs.webkit.org/show_bug.cgi?id=173450

Attachment 314739: Patch

https://bugs.webkit.org/attachment.cgi?id=314739&action=review




--- Comment #8 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 314739
  --> https://bugs.webkit.org/attachment.cgi?id=314739
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=314739&action=review

> Source/WebCore/rendering/InlineBox.cpp:119
> +    stream << boxName() << " " << FloatRect(x(), y(), width(), height()) <<
" (" << this << ") renderer->(" << &renderer() << ")";

I wonder if you should just add a TextStream& operator<<(TextStream&, const
InlineBox&) that dumps this.

Does it make sense to add InlineBox::frameRect() or boxRect() that returns the
rect?

> Source/WebCore/rendering/RenderObject.cpp:1032
> +    showRenderTreeLegend(stream);
> +    root->showRenderSubTreeAndMark(stream, this, 1);

The "show" in these names is misleading now.


More information about the webkit-reviews mailing list