[webkit-reviews] review granted: [Bug 168447] AX: when invert colors is on, double-invert certain media elements in UserAgentStyleSheet : [Attachment 329008] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 11 12:04:50 PST 2017


Dean Jackson <dino at apple.com> has granted James Craig <jcraig at apple.com>'s
request for review:
Bug 168447: AX: when invert colors is on, double-invert certain media elements
in UserAgentStyleSheet
https://bugs.webkit.org/show_bug.cgi?id=168447

Attachment 329008: patch

https://bugs.webkit.org/attachment.cgi?id=329008&action=review




--- Comment #28 from Dean Jackson <dino at apple.com> ---
Comment on attachment 329008
  --> https://bugs.webkit.org/attachment.cgi?id=329008
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=329008&action=review

> Source/WebCore/css/html.css:1223
> +    video { filter: invert(100%); }	/* Only videos double-inverted for now.
*/

Doesn't the rule on the media shadow tree do enough that you don't need this
rule?

> LayoutTests/accessibility/smart-invert.html:39
> +	   var resultString = filter === value ? "PASS" : "FAIL";
> +	   resultString += ": filter for " + el.tagName;
> +	   resultString += el.id ? "#" + el.id : "";
> +	   resultString += el.className ? "." + el.className : "";
> +	   resultString += " is '" + filter + "'.";
> +	   resultString += filter !== value ? "Expected: '" + value + "'." :
"";
> +	   resultString += msg ? " " + msg : "";
> +	   resultString += "<br>";

I'm finding `` strings more readable in these circumstances.


More information about the webkit-reviews mailing list